Unsplit archive issue

0
Hi,

I am trying to convert pvcs to svn using polarion tool.

To be safe side, i have copied the project folder(with archive folder) from server machine to a Virtual Machine.
I have created virtual drive using subst command to map it to same directory as it was in server machine.

Now, when i am trying to run tool, it throws exception for files those are split.
Even, i can't perform get operation on files with split attribute(Error:split archive must be accessed through file server).For unsplit files, its working fine.

I have checked server machine for client path(In my case, it is V:\Databases) and mapped to same in VM using subst command.But, it still throws error.

I even ran the "Version manager file server admin" and defined the same client path on Virtual machine.But still get the same error.

I went through the topics covering split issues here but did not work for my case.
Please suggest how to proceed.
Responses (4)
  • Accepted Answer

    Sunday, November 20 2016, 09:30 AM - #Permalink
    0
    Sorry, i did not copy revisions folder.
    Now, i copied and problems seems to be resolved.
    I don't know what is the significance of revisions folder here.But its working somehow.
    The reply is currently minimized Show
  • Accepted Answer

    Monday, November 28 2016, 03:15 AM - #Permalink
    1
    The revision folders hold the revision contents for split archives. Without them you only have dates, descriptions, labels and promotion groups.
    Like
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, November 29 2016, 01:13 AM - #Permalink
    0
    Thanks Richard.

    I don't know if you can help me with svn importer tool.But, i have stuck with this.
    i am using svn importer 1.3 and pvcs 8.4.0.0.
    While running this tool, it creates files.tmp and vlog.tmp files.However,after that it throws warning first for:
    "Date adjustment required for revision"
    "Labeled revision not found"
    After that it throws error:
    logParser expected Archive: but found Version Date ER Type Author Reviewer

    Please suggest here something.
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, November 29 2016, 03:40 AM - #Permalink
    0
    Hi Vivek,

    I'm afraid I can't help you here as neither of these error message come from Version Manager. As such your best bet it to contact the authors of the tool, as they ought to be able to explain under what circumstance this error is thrown. If the tool gets the "wrong" data from VM we need to understand what the tool tried to do in as much detail as possible, ideally showing the complete command executed and expected results. Likely it is making incorrect assumptions.

    Kind regards,

    - Richard.
    The reply is currently minimized Show
Your Reply

Recent Tweets